Search is broken

#1
The search function is well and truly stuffed. I mean if it returns NO results for the search term BMW then I'm Tom Cruise. It needs to be sorted because I don't want to have to sift through hundreds of pages to find what I want... :wut:
 

Kangal

Well-Known Member
#3
Anyway, if u have to check a single brand u can do it manually scrolling car by car, it's a thing u can do. But if u have to search on the ''Blueprints Donation'' forum, that's practically impossible without the working tool :(
 

exidge

Administrator
#4
It's a know technical/software issue without any solution so far. That's what you get when you use Vbulletin. And it's not just the character limit.

I'm trying to install Sphinx on the server, which should generate accurate search results - but this takes some time.

If someone has experience in this direction or has any other tips, please don't hesitate to post here.

Cheers,
exidge
 

exidge

Administrator
#6
..and nothing has changed more or less so far. Three characters always was a problem. Two seprate words was always a problem to get accurate results.

What is your solution?
 

Oscar J

Well-Known Member
#7
A tip for you guys until the function is working again: Google "site:smcars.net <insert what you're looking for here>"
 

exidge

Administrator
#9
It was walways a problem to search for three character on SMC. It is not new and it is not broken. Even though mysql would have a limit of 2 characters, you would still get inaccurate results: everything starting with BMW would be displayed.

Try to search for "Ferrari Modena" this has enough characters, but will display you all Ferraris. It was always like that and is a known issue. Solution for this is just to search for "Modena"

Cheers,
exidge
 

Kangal

Well-Known Member
#10
..and nothing has changed more or less so far. Three characters always was a problem. Two seprate words was always a problem to get accurate results.
No Ex, til yesterday u could do researches, even if not so accurate. Now it's completely out of order.
 

exidge

Administrator
#11
Hmm, we haven't changed anything on the server or the software. What exactly is working different now? Give some examples

Cheers,
exidge
 

Kangal

Well-Known Member
#12
If u type for example BMW in the search tool (archive forum) it says ''sorry no matches found''.
Til yesterday u had tons of results instead. The same if u type something in the advanced option focusing your target. No matches found, but i know that particular print (M6) there's, because i've seeen it before to try. Usually i go in the archive forum, i select ''advanced search'', then i click on one brand (BMW for example) so that it becomes blue, then i type the model (M6 for example). Now nothing happens.
 

exidge

Administrator
#13
hmmmm, maybe the character limit was reset with server restart or something. But we didn't have any offline delay on SMC so far as I know. Anyway, I will see what's up with the character limit.
This is annoying when you never can get accurate results. So I hope we can install sphinx on the server.

Cheers,
exidge
 

Kangal

Well-Known Member
#14
This is basical my friend to get new blueprints, because makes blueprints catcher's life simplier, and it will avoid double (or even triple) posts. Yesterday i've collected some interesting blueprints for SMC, hopefully to be able to post them soon :)
 

Pete-MJL

Active Member
#15
@exidge ( or any other Admin ) ,

As I posted earlier in the donations-section:

I think the problem with several of those “missing" blueprints is very simple:
One of the Admins should change the Valid file extensions for images and add the GIF file format ( now this is only: jpeg jpg pdf png rar zip )
Before the serious problems with hackers a while ago, everything worked fine, so...
Peter
 

Pete-MJL

Active Member
#18
Ow, what a pity. Many prints were uploaded as GIF, as it creates smaller files ( normally )
A lot of them can still be downloaded though, even if they don' t show up in the popup-window, so...

Peter
 

exidge

Administrator
#19
Ow, what a pity. Many prints were uploaded as GIF, as it creates smaller files ( normally )
A lot of them can still be downloaded though, even if they don' t show up in the popup-window, so...

Peter
Somehow GD/IM doesn't resitze "old" GIF files. That is why some of them are broken and some of them work. Many of the old GIFs are broken. InternetExplorer doesn't show some of the GIF files for example,too.
Generally, GIF is an outdated format. You can use PNG instead.

Cheers,
exidge